Start a new topic

Camera view

Hi everyone


My camera delivers two different views.

The regular view is a grey scale view with which I can position my material precise for the laser job.


But sometimes my camera delivers a different view (from more above, more colorfull and not in line with the working area) with which it is not possible to position materials for an accurate laser job (the laser lasers about 10mm beneath the meant position).


Has anyone made the same experiences and what is the problem / solution?


Thank you

Manuel


The normal camera view is dependant on the position of your MrBeams lid. The camera needs to identify the four red rings glued on the corners of the inside bottom of the MrBeam. As long as these rings are identified the MrBeam software has defined positioning information and can align the camera image to defined X/Y coordinates. If one or many of these rings are not visible (lid not fully opened / laser gantry in the way / material covering one/multiple ring(s)) then the described behaviour can occur and you see the natural image of the camera w/o alignment operations applied.

Since I sometimes cut materials covering one or more rings and thus causing this behaviour I've applied a simple "fix" to my MrBeam:

1) glued 3mm rubber foam at the bottom left corner
2) draw a big rectangular box in the MrBeam interface in the bottom left corner (0,0 mm position)
3) cut the foam accordingly.
4) result: defined 0,0 position by glued rubber foam => can be used for manual measuring irrespective of working camera alignment

If your camera is permanently misaligned you can do a camera recalibration - but mind: once the process is started MrBeamOS needs to finish the process, otherwise you end up in a calibration loop :-(

Thank you Benjamin. Have to admit that I didn‘t completely understand your self-made solution. But sometimes the solution is much simpler as thought in the first place... I think I discovered the cause for the two different camera views! There is a lamp above the desk Mr. Beam is placed on. Seems as this light, shining down on my Mr. Beam, causes reflections and confuses the camera. Since the light is switched off the camera reacts as expected, delivering a new picture approx. all 3 sek. So be careful with your desk lights!!!

Thanks Benni for your great support her on the forum. I love your answer. I want to add the current draft of the knowledgebase article I'm preparing:



Usually, Mr Beam II displays a black and white image of the working area. This image is suitable for camera based positioning of the designs, but a slight offset of up to +/- 5mm should be tolerated. (Link for manual positioning)

However, if Mr Beam II can not calibrate the image, it will output a color image showing not just the work area but the entire interior of the laser cutter. In this case positioning based on the image is not possible or very inaccurate. Most likely, the camera can not find or recognize the pink marks in the device, e.g. in case of unfavorable lighting or if one or more of the markings are covered.


What you can do in this case:

 - Check if all four pink circle markers are visible. If your work material or the axis of the Mr Beam obscure these markers for the camera, the image can not be adjusted correctly. 

- Close the lid of Mr Beam and open again. This will start a new camera session; Often that can help.

- Unfavorable lighting: Particularly strong light (eg direct sunshine) or particularly dark environments often disturbs our system. Try to provide "even lighting". (Then close the lid and open again.)

- Colored materials: Materials in bright colors (such as pink felt) can also mess up the recognition system.


A new calibration of the camera is only necessary if:

- one of the pink markings has been changed. (For example, if the mark was peeled off and glued in again.)

- you notice a larger deviation between the screen position on the adjusted (black-and-white image) and the laser result. But even then I recommend to test a new camera session first.


1 person likes this

So Andy, 


You say that a offset of 5 mm is acceptable?

There is no way to make the horizontal lineout more accurate?

(especially when engraving things the 5 mm offset is horrible) 



I do also experience issues with camera calibration sometimes.

Camera calibration doesn't always give the same results in terms of alignment.

If I open the lid after lasering the position of the cuts is not aligned with the position of the shapes having been cut.

image



I've done some experiments and seem to have a pretty consistent 4mm offset in the Y axis. I can get pretty good results by aligning the job on the camera view then editing the job by subtracting 4mm from the Y coordinate. Would it be possible to enter a offset to correct for this automatically?
Login or Signup to post a comment